What’s Vulnerable › Vulnerabilities
CVE-2025-13523: Cross-Site Scripting (XSS) via Unescaped Display Names in Mattermost Confluence Plugin OAuth2 Flow
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Mattermost Confluence plugin version <1.7.0 fails to properly escape user-controlled display names in HTML template rendering which allows authenticated Confluence users with malicious display names to execute arbitrary JavaScript in victim browsers via sending a specially crafted OAuth2 connection link that, when visited, renders the attacker's display name without proper sanitization. Mattermost Advisory ID: MMSA-2025-00557
Affected products
- Mattermost Confluence Plugin: from 1.0.0 before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Mattermost Confluence Plugin 1.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13523 or the next vulnerability affects your stack