What’s Vulnerable › Vulnerabilities
CVE-2025-13601: Glib: integer overflow in in g_escape_uri_string()
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-26 · updated 2026-10-18
- Weakness: CWE-190
Description
A heap-based buffer overflow problem was found in glib through an incorrect calculation of buffer size in the g_escape_uri_string() function. If the string to escape contains a very large number of unacceptable characters (which would need escaping), the calculation of the length of the escaped string could overflow, leading to a potential write off the end of the newly allocated string.
Affected products
- GNOME GLib: before 2.86.3 — fixed in 2.86.3
- Red Hat Ceph Storage: 8.0
- RedHat Codeready Linux Builder: 9.0
- RedHat Codeready Linux Builder For Arm64: 10.0, 8.0, 9.6
- RedHat Codeready Linux Builder For Arm64 Eus: 9.4, 10.0
- RedHat Codeready Linux Builder For Ibm Z Systems: 9.0_s390x, 10.0_s390x, 8.0_s390x, 9.4_s390x, 9.6_s390x
- RedHat Codeready Linux Builder For Ibm Z Systems Eus: 10.0_s390x
- RedHat Codeready Linux Builder For Power Little Endian: 9.0_ppc64le, 10.0_ppc64le, 8.0_ppc64le, 9.4_ppc64le, 9.6_ppc64le
- RedHat Codeready Linux Builder For Power Little Endian Eus: 10.0_ppc64le
- RedHat Codeready Linux Builder For X86 64: 9.0, 10.0, 8.0, 9.4, 9.6
- RedHat Codeready Linux Builder For X86 64 Eus: 10.0
- RedHat Discovery: 2.0
- RedHat Enterprise Linux For Arm 64: 9.0, 10.0, 8.0, 9.2, 9.4, 9.6
- RedHat Enterprise Linux For Arm 64 Eus: 10.0
- RedHat Enterprise Linux For Ibm Z Systems: 9.0_s390x, 10.0_s390x, 8.0_s390x, 9.2_s390x, 9.4_s390x, 9.6_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 10.0_s390x
- RedHat Enterprise Linux For Power Little Endian: 9.0_ppc64le, 10.0_ppc64le, 8.0_ppc64le, 9.2_ppc64le, 9.4_ppc64le, 9.6_ppc64le
- RedHat Enterprise Linux For Power Little Endian Eus: 10.0_ppc64le, 9.6_ppc64le
- RedHat Enterprise Linux For X86 64: 9.0, 10.0, 8.0, 9.2, 9.4, 9.6 (+2)
- RedHat Enterprise Linux For X86 64 Eus: 9.4, 10.0, 9.6, 8.6, 8.8, 8.4
- RedHat Enterprise Linux Server Aus: 9.2, 9.4, 9.6, 8.6, 8.4, 8.2
- RedHat Enterprise Linux Server For Power Little Endian: 9.4_ppc64le, 10.0_ppc64le, 9.6_ppc64le, 8.6_ppc64le, 8.8_ppc64le
- RedHat Enterprise Linux Server For Power Little Endian Eus: 9.4_ppc64le
- RedHat Enterprise Linux Server Tus: 8.6, 8.8
- Red Hat OpenShift Container Platform 4.18: 4.12, 4.16, 4.17, 4.18, 4.19
- RedHat Openshift Container Platform For Arm64: 4.12, 4.16, 4.17, 4.18, 4.19
- RedHat Openshift Container Platform For Ibm Z: 4.12, 4.16, 4.17, 4.18, 4.19
- RedHat Openshift Container Platform For Linuxone: 4.12, 4.16, 4.17, 4.18, 4.19
- RedHat Openshift Container Platform For Power: 4.12, 4.16, 4.17, 4.18, 4.19
How to fix
Upgrade to a fixed version: GNOME GLib 2.86.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:0936
- https://access.redhat.com/errata/RHSA-2026:0975
- https://access.redhat.com/errata/RHSA-2026:0991
- https://access.redhat.com/errata/RHSA-2026:1323
- https://access.redhat.com/errata/RHSA-2026:1324
- https://access.redhat.com/errata/RHSA-2026:1326
- https://access.redhat.com/errata/RHSA-2026:1327
- https://access.redhat.com/errata/RHSA-2026:1465
- https://access.redhat.com/errata/RHSA-2026:1608
- https://access.redhat.com/errata/RHSA-2026:1624
- https://access.redhat.com/errata/RHSA-2026:1625
- https://access.redhat.com/errata/RHSA-2026:1626
Get alerted when CVE-2025-13601 or the next vulnerability affects your stack