What’s Vulnerable › Vulnerabilities
CVE-2025-1361: IP2Location Country Blocker <= 2.38.8 - Missing Authorization to Unauthenticated Information Exposure via admin_init Function
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-22 · updated 2026-06-17
- Weakness: CWE-285
Description
The IP2Location Country Blocker plugin for WordPress is vulnerable to Regular Information Exposure in all versions up to, and including, 2.38.8 due to missing capability checks on the admin_init() function. This makes it possible for unauthenticated attackers to view the plugin's settings.
Affected products
- IP2Location Country Blocker: before 2.38.9 — fixed in 2.38.9
How to fix
Upgrade to a fixed version: IP2Location Country Blocker 2.38.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ip2location-country-blocker/trunk/ip2location-country-blocker.php#L114
- https://plugins.trac.wordpress.org/changeset/3244193/
- https://wordpress.org/plugins/ip2location-country-blocker/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b63bc2b6-1abc-4cfa-a7e5-3995640f66a7?source=cve
Get alerted when CVE-2025-1361 or the next vulnerability affects your stack