What’s Vulnerable › Vulnerabilities
CVE-2025-13643: MongoDB Server may allow queries to be terminated by unauthorized users
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-862
Description
A user with access to the cluster with a limited set of privilege actions may be able to terminate queries that are being executed by other users. This may cause a denial of service by preventing a fraction of queries from successfully completing. This issue affects MongoDB Server v7.0 versions prior to 7.0.26 and MongoDB Server v8.0 versions prior to 8.0.14
Affected products
- MongoDB: from 7.0.0 before 7.0.26; from 8.0.0 before 8.0.14; 8.2.0-alpha, 8.2.0-alpha0, 8.2.0-alpha1, 8.2.0-alpha2 — fixed in 7.0.26, 8.0.14
How to fix
Upgrade to a fixed version: MongoDB 7.0.26, 8.0.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13643 or the next vulnerability affects your stack