What’s Vulnerable › Vulnerabilities
CVE-2025-13688: DataStage on Cloud Pak for Data is vulnerable to arbitrary code injection due to runtime environment
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-03 · updated 2026-06-17
- Weakness: CWE-78
Description
IBM DataStage on Cloud Pak for Data 5.1.2 through 5.3.0 could allow an authenticated user to execute arbitrary commands with normal user privileges on the system due to improper validation of user supplied input through the wrapped command component.
Affected products
- IBM DataStage on Cloud Pak for Data: from 5.1.2 before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: IBM DataStage on Cloud Pak for Data 5.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13688 or the next vulnerability affects your stack