What’s Vulnerable › Vulnerabilities

CVE-2025-13690: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.11 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user to cause a denial of service condition due to improper input validation on webhook custom header names under certain conditions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.7.6, 18.8.6, 18.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13690 or the next vulnerability affects your stack