What’s Vulnerable › Vulnerabilities
CVE-2025-13736: Username Enumeration via Login Interface in Multiple WSO2 Products Allows User Account Discovery
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-29
- Weakness: CWE-203
Description
When Multi-Attribute Login is enabled, the login interface fails to consistently mask the existence of user accounts. For valid users, the server resolves and displays their canonical username, while for non-existent users, it echoes the original input. This occurs regardless of the validate_username configuration. The discovery of valid usernames can increase the risk of brute force attacks, social engineering attacks, and targeted information leakage. Attackers can leverage this information to craft more effective phishing campaigns or social engineering tactics to compromise user accounts or extract sensitive data.
Affected products
- WSO2 API Manager: from 3.1.0 before 3.1.0.351; from 3.2.0 before 3.2.0.455; from 4.0.0 before 4.0.0.375 — fixed in 3.1.0.351, 3.2.0.455, 4.0.0.375
- WSO2 Identity Server: from 5.10.0 before 5.10.0.380; from 5.11.0 before 5.11.0.427; from 6.0.0 before 6.0.0.254; from 6.1.0 before 6.1.0.255; from 7.0.0 before 7.0.0.132; from 7.1.0 before 7.1.0.40 — fixed in 5.10.0.380, 5.11.0.427, 6.0.0.254, 6.1.0.255, 7.0.0.132, 7.1.0.40
- WSO2 Identity Server As Key Manager: from 5.10.0 before 5.10.0.371 — fixed in 5.10.0.371
- WSO2 Open Banking Am: from 2.0.0 before 2.0.0.400 — fixed in 2.0.0.400
- WSO2 Open Banking Iam: from 2.0.0 before 2.0.0.420 — fixed in 2.0.0.420
How to fix
Upgrade to a fixed version: WSO2 API Manager 3.1.0.351, 3.2.0.455, 4.0.0.375; WSO2 Identity Server 5.10.0.380, 5.11.0.427, 6.0.0.254, 6.1.0.255; WSO2 Identity Server As Key Manager 5.10.0.371; WSO2 Open Banking Am 2.0.0.400; WSO2 Open Banking Iam 2.0.0.420. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13736 or the next vulnerability affects your stack