What’s Vulnerable › Vulnerabilities
CVE-2025-13822: Authentication bypass in MCPHub
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-14 · updated 2026-10-14
- Weakness: CWE-639
Description
MCPHub in versions below 0.11.0 is vulnerable to authentication bypass. Some endpoints are not protected by authentication middleware, allowing an unauthenticated attacker to perform actions in the name of other users and using their privileges.
Affected products
- samanhappy mcphub: before 0.11.0 — fixed in 0.11.0
How to fix
Upgrade to a fixed version: samanhappy mcphub 0.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13822 or the next vulnerability affects your stack