What’s Vulnerable › Vulnerabilities
CVE-2025-1383: Podlove Podcast Publisher <= 4.2.2 - Cross-Site Request Forgery via ajax_transcript_delete Function
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-06 · updated 2026-06-17
- Weakness: CWE-352
Description
The Podlove Podcast Publisher plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.2. This is due to missing or incorrect nonce validation on the ajax_transcript_delete() function. This makes it possible for unauthenticated attackers to delete arbitrary episode transcripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Podlove Podcast Publisher: before 4.2.3 — fixed in 4.2.3
How to fix
Upgrade to a fixed version: Podlove Podcast Publisher 4.2.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/podlove-podcasting-plugin-for-wordpress/tags/4.2.0/lib/modules/transcripts/transcripts.php#L223
- https://plugins.trac.wordpress.org/changeset/3246867/
- https://wordpress.org/plugins/podlove-podcasting-plugin-for-wordpress/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/00a95ae7-3c58-4e5e-aaef-c04d1dacf27f?source=cve
Get alerted when CVE-2025-1383 or the next vulnerability affects your stack