What’s Vulnerable › Vulnerabilities

CVE-2025-13870: Unauthorized access and subscription vulnerability in Boards

Description

Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to the block in Boards, which allows an authenticated user to access other board files and was able to subscribe to the block from other boards that the user does not have access to

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.5, 10.5.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13870 or the next vulnerability affects your stack