What’s Vulnerable › Vulnerabilities
CVE-2025-13914: Apstra: SSH host key validation vulnerability for managed devices
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-10-07
- Weakness: CWE-322
Description
A Key Exchange without Entity Authentication vulnerability in the SSH implementation of Juniper Networks Apstra allows a unauthenticated, MITM attacker to impersonate managed devices. Due to insufficient SSH host key validation an attacker can perform a machine-in-the-middle attack on the SSH connections from Apstra to managed devices, enabling an attacker to impersonate a managed device and capture user credentials. This issue affects all versions of Apstra before 6.1.1.
Affected products
- Juniper Networks Apstra: before 6.1.1 — fixed in 6.1.1
How to fix
Upgrade to a fixed version: Juniper Networks Apstra 6.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13914 or the next vulnerability affects your stack