What’s Vulnerable › Vulnerabilities
CVE-2025-13921: weDocs <= 2.1.16 - Missing Authorization to Authenticated (Subscriber+) Documentation Post Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-23 · updated 2026-06-17
- Weakness: CWE-862
Description
The weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot plugin for WordPress is vulnerable to unauthorized modification or loss of data due to a missing capability check on the 'wedocs_user_documentation_handling_capabilities' function in all versions up to, and including, 2.1.16. This makes it possible for authenticated attackers, with Subscriber-level access and above, to edit any documentation post. The vulnerability was partially patched in version 2.1.16.
Affected products
References
- https://plugins.trac.wordpress.org/browser/wedocs/tags/2.1.14/includes/Installer.php#L21
- https://plugins.trac.wordpress.org/browser/wedocs/tags/2.1.14/includes/functions.php#L506
- https://plugins.trac.wordpress.org/changeset/3426704/
- https://plugins.trac.wordpress.org/changeset/3440068/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c56234f3-7dd6-4dff-887d-5ddbf0cb7d3c?source=cve
Get alerted when CVE-2025-13921 or the next vulnerability affects your stack