What’s Vulnerable › Vulnerabilities

CVE-2025-13927: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.9 before 18.6.4, 18.7 before 18.7.2, and 18.8 before 18.8.2 that could have allowed an unauthenticated user to create a denial of service condition by sending crafted requests with malformed authentication data.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.6.4, 18.7.2, 18.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13927 or the next vulnerability affects your stack