What’s Vulnerable › Vulnerabilities

CVE-2025-13928: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.7 before 18.6.4, 18.7 before 18.7.2, and 18.8 before 18.8.2 that could have allowed an unauthenticated user to cause a denial of service condition by exploiting incorrect authorization validation in API endpoints.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.6.4, 18.7.2, 18.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13928 or the next vulnerability affects your stack