What’s Vulnerable › Vulnerabilities

CVE-2025-13942

Description

A command injection vulnerability in the UPnP function of the Zyxel EX3510-B0 firmware versions through 5.17(ABUP.15.1)C0 could allow a remote attacker to execute operating system (OS) commands on an affected device by sending specially crafted UPnP SOAP requests.

Affected products

How to fix

Upgrade to a fixed version: Zyxel Dx4510-B0 Firmware 5.17\(abyl.10.1\)c0; Zyxel Dx4510-B1 Firmware 5.17\(abyl.10.1\)c0; Zyxel Ee6510-10 Firmware 5.19\(acjq.4.1\)c0; Zyxel Emg6726-B10A Firmware 5.13\(abnp.8.2\)c1; Zyxel Ex2210-T0 Firmware 5.50\(acdi.2.4\)c0; Zyxel EX3510-B0 firmware 5.17\(abup.15.2\)c0; Zyxel Ex3510-B1 Firmware 5.17\(abup.15.2\)c0; Zyxel Ex5510-B0 Firmware 5.17\(abqx.11.1\)c0; Zyxel Ex5512-T0 Firmware 5.70\(aceg.5.4\)c0; Zyxel Ex7710-B0 Firmware 5.18\(acak.1.6\)c0; Zyxel Lte3301-Plus Firmware 1.00\(abqu.9\)c0; Zyxel Nebula Lte3301-Plus Firmware 1.18\(acca.6\)v0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13942 or the next vulnerability affects your stack