What’s Vulnerable › Vulnerabilities

CVE-2025-13978: Generation of Error Message Containing Sensitive Information in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.5 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to discover the names of private projects they do not have access through API requests.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.4.6, 18.5.4, 18.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13978 or the next vulnerability affects your stack