What’s Vulnerable › Vulnerabilities
CVE-2025-13984: Next.js - Critical - Access bypass - SA-CONTRIB-2025-122
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-942
Description
Permissive Cross-domain Security Policy with Untrusted Domains vulnerability in Drupal Next.Js allows Cross-Site Scripting (XSS).This issue affects Next.Js: from 0.0.0 before 1.6.4, from 2.0.0 before 2.0.1.
Affected products
- Drupal Next.js: before 1.6.4; from 2.0.0 before 2.0.1 — fixed in 1.6.4, 2.0.1
How to fix
Upgrade to a fixed version: Drupal Next.js 1.6.4, 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13984 or the next vulnerability affects your stack