What’s Vulnerable › Vulnerabilities
CVE-2025-14009: Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-18 · updated 2026-07-15
- Weakness: CWE-94
Description
A critical vulnerability exists in the NLTK downloader component of nltk/nltk, affecting all versions. The _unzip_iter function in nltk/downloader.py uses zipfile.extractall() without performing path validation or security checks. This allows attackers to craft malicious zip packages that, when downloaded and extracted by NLTK, can execute arbitrary code. The vulnerability arises because NLTK assumes all downloaded packages are trusted and extracts them without validation. If a malicious package contains Python files, such as __init__.py, these files are executed automatically upon import, leading to remote code execution. This issue can result in full system compromise, including file system access, network access, and potential persistence mechanisms.
Affected products
- nltk: before 3.9.3 — fixed in 3.9.3
How to fix
Upgrade to a fixed version: nltk 3.9.3. Check the vendor advisory for mitigations.
References
- https://huntr.com/bounties/49ecbc02-054e-4470-b2e0-b267936cc4e4
- https://access.redhat.com/errata/RHSA-2026:10184
- https://access.redhat.com/security/cve/CVE-2025-14009
- https://bugzilla.redhat.com/show_bug.cgi?id=2440724
- https://huntr.com/bounties/49ecbc02-054e-4470-b2e0-b267936cc4e4
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-14009.json
Get alerted when CVE-2025-14009 or the next vulnerability affects your stack