What’s Vulnerable › Vulnerabilities
CVE-2025-1402: Event Tickets and Registration <= 5.19.1.1 - Missing Authorization to Ticket Deletion
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-862
Description
The Event Tickets and Registration plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'ajax_ticket_delete' function in all versions up to, and including, 5.19.1.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary Attendee tickets.
Affected products
- theeventscalendar Event Tickets: before 5.19.1.2 — fixed in 5.19.1.2
How to fix
Upgrade to a fixed version: theeventscalendar Event Tickets 5.19.1.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/event-tickets/tags/5.18.1/src/Tribe/Assets.php#L202
- https://plugins.trac.wordpress.org/browser/event-tickets/tags/5.18.1/src/Tribe/Metabox.php#L30
- https://plugins.trac.wordpress.org/browser/event-tickets/tags/5.18.1/src/Tribe/Metabox.php#L490
- https://wordfence.freshdesk.com/a/tickets/375051
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dbd838b6-7792-4378-8969-a70c6e16ff6a?source=cve
Get alerted when CVE-2025-1402 or the next vulnerability affects your stack