What’s Vulnerable › Vulnerabilities
CVE-2025-14046: Insufficient HTML Sanitization Allows User-Controlled DOM Elements to Overwrite Server-Initialized Data Islands and Trigger Unintended Server-Side POST Requests
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-11 · updated 2026-10-07
- Weakness: CWE-79
Description
An improper neutralization of input vulnerability was identified in GitHub Enterprise Server that allowed user-supplied HTML to inject DOM elements with IDs that collided with server-initialized data islands. These collisions could overwrite or shadow critical application state objects used by certain Project views, leading to unintended server-side POST requests or other unauthorized backend interactions. Successful exploitation requires an attacker to have access to the target GitHub Enterprise Server instance and to entice a privileged user to view crafted malicious content that includes conflicting HTML elements. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18.3, 3.17.9, 3.16.12, 3.15.16, and 3.14.21.
Affected products
- GitHub Enterprise Server: before 3.14.21; from 3.15.0 before 3.15.16; from 3.16.0 before 3.16.12; from 3.17.0 before 3.17.9; from 3.18.0 before 3.18.3 — fixed in 3.14.21, 3.15.16, 3.16.12, 3.17.9, 3.18.3
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.14.21, 3.15.16, 3.16.12, 3.17.9. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.21
- https://docs.github.com/en/enterprise-server@3.15/admin/release-notes#3.15.16
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.12
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.9
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.3
Get alerted when CVE-2025-14046 or the next vulnerability affects your stack