What’s Vulnerable › Vulnerabilities
CVE-2025-14087: Glib: glib: buffer underflow in gvariant parser leads to heap corruption
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-10 · updated 2026-10-14
- Weakness: CWE-190
Description
A flaw was found in GLib (Gnome Lib). This vulnerability allows a remote attacker to cause heap corruption, leading to a denial of service or potential code execution via a buffer-underflow in the GVariant parser when processing maliciously crafted input strings.
Affected products
- GNOME GLib: before 2.86.3 — fixed in 2.86.3
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0, 10.0
How to fix
Upgrade to a fixed version: GNOME GLib 2.86.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:15953
- https://access.redhat.com/errata/RHSA-2026:15969
- https://access.redhat.com/errata/RHSA-2026:15971
- https://access.redhat.com/errata/RHSA-2026:19148
- https://access.redhat.com/errata/RHSA-2026:19361
- https://access.redhat.com/errata/RHSA-2026:19452
- https://access.redhat.com/errata/RHSA-2026:19457
- https://access.redhat.com/errata/RHSA-2026:19459
- https://access.redhat.com/errata/RHSA-2026:19460
- https://access.redhat.com/errata/RHSA-2026:19523
- https://access.redhat.com/errata/RHSA-2026:19524
- https://access.redhat.com/errata/RHSA-2026:19565
Get alerted when CVE-2025-14087 or the next vulnerability affects your stack