What’s Vulnerable › Vulnerabilities
CVE-2025-1410: Events Calendar Made Simple – Pie Calendar <= 1.2.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via piecal Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Events Calendar Made Simple – Pie Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's piecal shortcode in all versions up to, and including, 1.2.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- apexws Pie Calendar – Events Calendar Made Simple: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: apexws Pie Calendar – Events Calendar Made Simple 1.2.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3243992/
- https://wordpress.org/plugins/pie-calendar/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fcaea2fb-ebf8-49b4-8cd5-0d9208252a90?source=cve
Get alerted when CVE-2025-1410 or the next vulnerability affects your stack