What’s Vulnerable › Vulnerabilities

CVE-2025-14103: Missing Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.7 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have allowed an unauthorized user with Developer-role permissions to set pipeline variables for manually triggered jobs under certain conditions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.7.5, 18.8.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-14103 or the next vulnerability affects your stack