What’s Vulnerable › Vulnerabilities
CVE-2025-14104: Util-linux: util-linux: heap buffer overread in setpwnam() when processing 256-byte usernames
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-10-18
- Weakness: CWE-125
Description
A flaw was found in util-linux. This vulnerability allows a heap buffer overread when processing 256-byte usernames, specifically within the `setpwnam()` function, affecting SUID (Set User ID) login-utils utilities writing to the password database.
Affected products
- util-linux: before 2.41.3 — fixed in 2.41.3
- Red Hat Cert Manager support for Red Hat OpenShift release 1.18: all versions — fixed in 1789029076, 1791459707, 1791459711, 1791459759, 1791966259
- Red Hat OpenShift Container Platform 4.18: all versions
- Red Hat Ceph Storage 7: all versions — fixed in 1770632724
- Red Hat Ceph Storage 8: all versions — fixed in 1770630907
- Red Hat Ceph Storage 9: all versions — fixed in 1771816028
- Red Hat Enterprise Linux 10: all versions — fixed in 0:2.40.2-15.el10_1
- Red Hat Enterprise Linux 6: all versions
- Red Hat Enterprise Linux 7: all versions
- Red Hat Enterprise Linux 8: all versions — fixed in 0:2.32.1-48.el8_10
- Red Hat Enterprise Linux 9: all versions — fixed in 0:2.37.4-21.el9_7
- Red Hat Hardened Images: all versions — fixed in 2.42-7.1.hum1
- Red Hat Insights proxy 1.5: all versions — fixed in 1770740405
- Red Hat Update Infrastructure 5: all versions — fixed in 1770646925, 1773670073, 1773670137, 1773672059
How to fix
Upgrade to a fixed version: util-linux 2.41.3; Red Hat Cert Manager support for Red Hat OpenShift release 1.18 1789029076, 1791459707, 1791459711, 1791459759; Red Hat Ceph Storage 7 1770632724; Red Hat Ceph Storage 8 1770630907; Red Hat Ceph Storage 9 1771816028; Red Hat Enterprise Linux 10 0:2.40.2-15.el10_1; Red Hat Enterprise Linux 8 0:2.32.1-48.el8_10; Red Hat Enterprise Linux 9 0:2.37.4-21.el9_7; Red Hat Hardened Images 2.42-7.1.hum1; Red Hat Insights proxy 1.5 1770740405; Red Hat Update Infrastructure 5 1770646925, 1773670073, 1773670137, 1773672059. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:1696
- https://access.redhat.com/errata/RHSA-2026:1852
- https://access.redhat.com/errata/RHSA-2026:1913
- https://access.redhat.com/errata/RHSA-2026:2485
- https://access.redhat.com/errata/RHSA-2026:2563
- https://access.redhat.com/errata/RHSA-2026:2737
- https://access.redhat.com/errata/RHSA-2026:2800
- https://access.redhat.com/errata/RHSA-2026:3406
- https://access.redhat.com/errata/RHSA-2026:4943
- https://access.redhat.com/errata/RHSA-2026:7180
- https://access.redhat.com/errata/RHSA-2026:82347
- https://access.redhat.com/errata/RHSA-2026:82354
Get alerted when CVE-2025-14104 or the next vulnerability affects your stack