What’s Vulnerable › Vulnerabilities

CVE-2025-1412: Session Persistence After User-to-Bot Conversion

Description

Mattermost versions 9.11.x <= 9.11.6, 10.4.x <= 10.4.1 fail to invalidate all active sessions when converting a user to a bot, with allows the converted user to escalate their privileges depending on the permissions granted to the bot.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.4.2, 9.11.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1412 or the next vulnerability affects your stack