What’s Vulnerable › Vulnerabilities
CVE-2025-1413: Dylib Hijacking in DaVinci Resolve
- Severity: high (CVSS 8.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-732
Description
DaVinci Resolve on MacOS was found to be installed with incorrect file permissions (rwxrwxrwx). This is inconsistent with standard macOS security practices, where applications should have drwxr-xr-x permissions. Incorrect permissions allow for Dylib Hijacking. Guest account, other users and applications can exploit this vulnerability for privilege escalation. This issue affects DaVinci Resolve on MacOS in versions before 19.1.3.
Affected products
- Blackmagic Design Inc DaVinci Resolve: before 19.1.3 — fixed in 19.1.3
How to fix
Upgrade to a fixed version: Blackmagic Design Inc DaVinci Resolve 19.1.3. Check the vendor advisory for mitigations.
References
- https://apps.apple.com/pl/app/davinci-resolve/id571213070?mt=12
- https://cert.pl/en/posts/2025/02/CVE-2025-1413/
- https://cert.pl/posts/2025/02/CVE-2025-1413/
Get alerted when CVE-2025-1413 or the next vulnerability affects your stack