What’s Vulnerable › Vulnerabilities
CVE-2025-14148: IBM DevOps Deploy is susceptible to a Insufficiently Protected Credentials vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-15 · updated 2026-10-07
- Weakness: CWE-522
Description
IBM UCD - IBM DevOps Deploy 8.1 through 8.1.2.3 could allow an authenticated user with LLM integration configuration privileges to recover a previously saved LLM API Token.
Affected products
- IBM DevOps Deploy: from 8.1.0.0 before 8.1.2.4 — fixed in 8.1.2.4
How to fix
Upgrade to a fixed version: IBM DevOps Deploy 8.1.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-14148 or the next vulnerability affects your stack