What’s Vulnerable › Vulnerabilities
CVE-2025-14178: Heap buffer overflow in array_merge()
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-27 · updated 2026-10-13
- Weakness: CWE-190
Description
In PHP versions:8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1, a heap buffer overflow occurs in array_merge() when the total element count of packed arrays exceeds 32-bit limits or HT_MAX_SIZE, due to an integer overflow in the precomputation of element counts using zend_hash_num_elements(). This may lead to memory corruption or crashes and affect the integrity and availability of the target server.
Affected products
- PHP: from 8.1.0 before 8.1.34; from 8.2.0 before 8.2.30; from 8.3.0 before 8.3.29; from 8.4.0 before 8.4.16; from 8.5.0 before 8.5.1 — fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1
How to fix
Upgrade to a fixed version: PHP 8.1.34, 8.2.30, 8.3.29, 8.4.16. Check the vendor advisory for mitigations.
References
- https://github.com/php/php-src/security/advisories/GHSA-h96m-rvf9-jgm2
- https://lists.debian.org/debian-lts-announce/2026/01/msg00019.html
Get alerted when CVE-2025-14178 or the next vulnerability affects your stack