What’s Vulnerable › Vulnerabilities
CVE-2025-14260: Server Side Request Forgery in Multiple WSO2 Products Allows Access to Internal and External Resources
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-28 · updated 2026-10-29
- Weakness: CWE-918
Description
Due to the improper implementation of access control rules, the WSO2 product accepts user-supplied input related to resource location without enforcing expected validation constraints. This can be exploited by an unauthenticated actor to direct the server to make requests to arbitrary network locations. Exploiting this vulnerability allows a malicious actor to access both internal and external resources, available through the network or filesystem, that are reachable by the WSO2 product. This could potentially lead to unauthorized access to sensitive data and systems.
Affected products
- WSO2 API Manager: from 3.1.0 before 3.1.0.354; from 3.2.0 before 3.2.0.458; from 3.2.1 before 3.2.1.99; from 4.0.0 before 4.0.0.379; from 4.1.0 before 4.1.0.265; from 4.2.0 before 4.2.0.205 — fixed in 3.1.0.354, 3.2.0.458, 3.2.1.99, 4.0.0.379, 4.1.0.265, 4.2.0.205
- WSO2 Identity Server: from 5.10.0 before 5.10.0.383; from 5.11.0 before 5.11.0.430; from 6.0.0 before 6.0.0.256; from 6.1.0 before 6.1.0.257; from 7.0.0 before 7.0.0.134 — fixed in 5.10.0.383, 5.11.0.430, 6.0.0.256, 6.1.0.257, 7.0.0.134
- WSO2 Identity Server As Key Manager: from 5.10.0 before 5.10.0.374 — fixed in 5.10.0.374
- WSO2 Open Banking Am: from 2.0.0 before 2.0.0.403 — fixed in 2.0.0.403
- WSO2 Open Banking Iam: from 2.0.0 before 2.0.0.423 — fixed in 2.0.0.423
- WSO2 SAML2 SSO Authenticator UI Bundle: from 5.5.0 before 5.5.0.2; from 5.5.2 before 5.5.2.5; from 5.5.9 before 5.5.9.4; from 5.5.10 before 5.5.10.1; from 5.6.4 before 5.6.4.1; from 5.7.2 before 5.7.2.1 — fixed in 5.5.0.2, 5.5.2.5, 5.5.9.4, 5.5.10.1, 5.6.4.1, 5.7.2.1
- WSO2 Carbon UI: from 4.6.0 before 4.6.0.2300; from 4.6.1 before 4.6.1.165; from 4.6.3 before 4.6.3.46; from 4.6.4 before 4.6.4.28; from 4.7.1 before 4.7.1.79; from 4.8.1 before 4.8.1.50 — fixed in 4.6.0.2300, 4.6.1.165, 4.6.3.46, 4.6.4.28, 4.7.1.79, 4.8.1.50
How to fix
Upgrade to a fixed version: WSO2 API Manager 3.1.0.354, 3.2.0.458, 3.2.1.99, 4.0.0.379; WSO2 Identity Server 5.10.0.383, 5.11.0.430, 6.0.0.256, 6.1.0.257; WSO2 Identity Server As Key Manager 5.10.0.374; WSO2 Open Banking Am 2.0.0.403; WSO2 Open Banking Iam 2.0.0.423; WSO2 SAML2 SSO Authenticator UI Bundle 5.5.0.2, 5.5.2.5, 5.5.9.4, 5.5.10.1; WSO2 Carbon UI 4.6.0.2300, 4.6.1.165, 4.6.3.46, 4.6.4.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-14260 or the next vulnerability affects your stack