What’s Vulnerable › Vulnerabilities
CVE-2025-14261: Lack of entropy allows registered low-privileged users of Litmus to crack valid JWT tokens and gain admin privileges
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-08 · updated 2026-10-07
- Weakness: CWE-331
Description
The Litmus platform uses JWT for authentication and authorization, but the secret being used for signing the JWT is only 6 bytes long at its core, which makes it extremely easy to crack.
Affected products
- LitmusChaos Litmus: before 3.23.0 — fixed in 3.23.0
How to fix
Upgrade to a fixed version: LitmusChaos Litmus 3.23.0. Check the vendor advisory for mitigations.
References
- https://github.com/litmuschaos/litmus/pull/5324
- https://research.jfrog.com/vulnerabilities/litmus-jwt-missing-entropy-elevation-jfsa-2025-001648159/
Get alerted when CVE-2025-14261 or the next vulnerability affects your stack