What’s Vulnerable › Vulnerabilities
CVE-2025-14280: PixelYourSite <= 11.1.5 - Sensitive Information Exposure via Log File
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-29 · updated 2026-10-07
- Weakness: CWE-200
Description
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.
Affected products
- PixelYourSite – Your smart PIXEL (TAG) & API Manager: through 11.1.5
References
- https://plugins.trac.wordpress.org/browser/pixelyoursite/tags/11.1.4.2/includes/logger/class-pys-logger.php#L118
- https://plugins.trac.wordpress.org/changeset/3416113/pixelyoursite
- https://plugins.trac.wordpress.org/changeset/3424175/pixelyoursite
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0fe77926-8a43-42ce-9d3d-3aac2334dcbd?source=cve
Get alerted when CVE-2025-14280 or the next vulnerability affects your stack