What’s Vulnerable › Vulnerabilities
CVE-2025-14284
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-09 · updated 2026-10-14
- Weakness: CWE-79
Description
Versions of the package @tiptap/extension-link before 2.10.4 are vulnerable to Cross-site Scripting (XSS) due to unsanitized user input allowed in setting or toggling links. An attacker can execute arbitrary JavaScript code in the context of the application by injecting a javascript: URL payload into these attributes, which is then triggered either by user interaction.
Affected products
- @tiptap/extension-link: before 2.10.4 — fixed in 2.10.4
How to fix
Upgrade to a fixed version: @tiptap/extension-link 2.10.4. Check the vendor advisory for mitigations.
References
- https://gist.github.com/th4s1s/3d1b6cd3e7257b14947242f712ec6e1f
- https://github.com/ueberdosis/tiptap/commit/1c2fefe3d61ab1c8fbaa6d6b597251e1b6d9aaed
- https://github.com/ueberdosis/tiptap/releases/tag/v2.10.4
- https://security.snyk.io/vuln/SNYK-JS-TIPTAPEXTENSIONLINK-14222197
- https://gist.github.com/th4s1s/3d1b6cd3e7257b14947242f712ec6e1f
Get alerted when CVE-2025-14284 or the next vulnerability affects your stack