What’s Vulnerable › Vulnerabilities
CVE-2025-14287: Command Injection in mlflow/mlflow
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-16 · updated 2026-07-15
- Weakness: CWE-94
Description
A command injection vulnerability exists in mlflow/mlflow versions before v3.7.0, specifically in the `mlflow/sagemaker/__init__.py` file at lines 161-167. The vulnerability arises from the direct interpolation of user-supplied container image names into shell commands without proper sanitization, which are then executed using `os.system()`. This allows attackers to execute arbitrary commands by supplying malicious input through the `--container` parameter of the CLI. The issue affects environments where MLflow is used, including development setups, CI/CD pipelines, and cloud deployments.
Affected products
- mlflow/mlflow: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: mlflow/mlflow 3.7.0. Check the vendor advisory for mitigations.
References
- https://huntr.com/bounties/229cd526-41aa-4819-b6f0-e2d0371c89e3
- https://access.redhat.com/security/cve/CVE-2025-14287
- https://bugzilla.redhat.com/show_bug.cgi?id=2447690
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-14287.json
Get alerted when CVE-2025-14287 or the next vulnerability affects your stack