What’s Vulnerable › Vulnerabilities
CVE-2025-14323: Privilege escalation in the DOM: Notifications component
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-07
Description
Privilege escalation in the DOM: Notifications component. This vulnerability was fixed in Firefox 146, Firefox ESR 115.31, Firefox ESR 140.6, Thunderbird 146, and Thunderbird 140.6.
Affected products
- Mozilla Firefox: before 115.31.0; before 146.0; from 116.0 before 140.6.0 — fixed in 115.31.0, 140.6.0, 146.0
- Mozilla Thunderbird: before 140.6.0; before 146.0 — fixed in 140.6.0, 146.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 115.31.0, 140.6.0, 146.0; Mozilla Thunderbird 140.6.0, 146.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1996555
- https://www.mozilla.org/security/advisories/mfsa2025-92/
- https://www.mozilla.org/security/advisories/mfsa2025-93/
- https://www.mozilla.org/security/advisories/mfsa2025-94/
- https://www.mozilla.org/security/advisories/mfsa2025-95/
- https://www.mozilla.org/security/advisories/mfsa2025-96/
Get alerted when CVE-2025-14323 or the next vulnerability affects your stack