What’s Vulnerable › Vulnerabilities
CVE-2025-14434: Ultimate Post Kit < 4.0.16 – Unauthenticated Arbitrary Post Content Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-31 · updated 2026-06-17
Description
The Ultimate Post Kit Addons for Elementor WordPress plugin before 4.0.16 exposes multiple AJAX “load more” endpoints such as upk_alex_grid_loadmore_posts without ensuring that posts to be displayed are published authentication. This allows an unauthenticated attacker to query arbitrary posts and retrieve rendered HTML content of private and unpublished ones.
Affected products
- Ultimate Post Kit Addons for Elementor: before 4.0.16 — fixed in 4.0.16
How to fix
Upgrade to a fixed version: Ultimate Post Kit Addons for Elementor 4.0.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bf3c3193-fc9c-454b-ad4f-94ba1669a312/
- https://wpscan.com/vulnerability/bf3c3193-fc9c-454b-ad4f-94ba1669a312/
Get alerted when CVE-2025-14434 or the next vulnerability affects your stack