What’s Vulnerable › Vulnerabilities

CVE-2025-14435: Application-Level DoS via infinite re-render loop in user profile handling

Description

Mattermost versions 10.11.x <= 10.11.8, 11.1.x <= 11.1.1, 11.0.x <= 11.0.6 fail to prevent infinite re-renders on API errors which allows authenticated users to cause application-level DoS via triggering unbounded component re-render loops.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.9, 11.0.7, 11.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-14435 or the next vulnerability affects your stack