What’s Vulnerable › Vulnerabilities
CVE-2025-14511: Improper Validation of Specified Quantity in Input in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-1284
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.2 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have allowed an unauthenticated user to cause denial of service by sending specially crafted files to the container registry event endpoint under certain conditions.
Affected products
- GitLab: from 12.2.0 before 18.7.5; from 18.8.0 before 18.8.5; 18.9.0 — fixed in 18.7.5, 18.8.5
How to fix
Upgrade to a fixed version: GitLab 18.7.5, 18.8.5. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/02/25/patch-release-gitlab-18-9-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/583717
- https://hackerone.com/reports/3452200
Get alerted when CVE-2025-14511 or the next vulnerability affects your stack