What’s Vulnerable › Vulnerabilities
CVE-2025-14512: Glib: integer overflow in glib gio attribute escaping causes heap buffer overflow
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-11 · updated 2026-10-14
- Weakness: CWE-190
Description
A flaw was found in glib. This vulnerability allows a heap buffer overflow and denial-of-service (DoS) via an integer overflow in GLib's GIO (GLib Input/Output) escape_byte_string() function when processing malicious file or remote filesystem attribute values.
Affected products
- GNOME GLib: before 2.86.3 — fixed in 2.86.3
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0, 10.0
- Openshift: 4.0
How to fix
Upgrade to a fixed version: GNOME GLib 2.86.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:15953
- https://access.redhat.com/errata/RHSA-2026:15969
- https://access.redhat.com/errata/RHSA-2026:15971
- https://access.redhat.com/errata/RHSA-2026:19148
- https://access.redhat.com/errata/RHSA-2026:19361
- https://access.redhat.com/errata/RHSA-2026:19452
- https://access.redhat.com/errata/RHSA-2026:19457
- https://access.redhat.com/errata/RHSA-2026:19459
- https://access.redhat.com/errata/RHSA-2026:19460
- https://access.redhat.com/errata/RHSA-2026:19523
- https://access.redhat.com/errata/RHSA-2026:19524
- https://access.redhat.com/errata/RHSA-2026:19565
Get alerted when CVE-2025-14512 or the next vulnerability affects your stack