What’s Vulnerable › Vulnerabilities

CVE-2025-14550: Potential denial-of-service vulnerability via repeated headers when using ASGI

Description

An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28. `ASGIRequest` allows a remote attacker to cause a potential denial-of-service via a crafted request with multiple duplicate headers. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Jiyong Yang for reporting this issue.

Affected products

How to fix

Upgrade to a fixed version: Django 4.2.28, 5.2.11, 6.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-14550 or the next vulnerability affects your stack