What’s Vulnerable › Vulnerabilities
CVE-2025-14560: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-11 · updated 2026-06-17
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.1 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions could have allowed an authenticated user to perform unauthorized actions on behalf of another user by injecting malicious content into vulnerability code flow.
Affected products
- GitLab: from 17.1.0 before 18.6.6; from 18.7.0 before 18.7.4; from 18.8.0 before 18.8.4 — fixed in 18.6.6, 18.7.4, 18.8.4
How to fix
Upgrade to a fixed version: GitLab 18.6.6, 18.7.4, 18.8.4. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/02/10/patch-release-gitlab-18-8-4-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/583861
- https://hackerone.com/reports/3461083
Get alerted when CVE-2025-14560 or the next vulnerability affects your stack