What’s Vulnerable › Vulnerabilities
CVE-2025-14562: Incorrect Authorization in GitLab
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-09-29
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.6 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to commit changes to a project after being removed as a member, due to improper authorization checks on merge request collaboration settings.
Affected products
- GitLab: from 10.6.0 before 19.0.5; from 19.1.0 before 19.1.3; 19.2.0 — fixed in 19.0.5, 19.1.3
How to fix
Upgrade to a fixed version: GitLab 19.0.5, 19.1.3. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-2-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/583889
- https://hackerone.com/reports/3460445
Get alerted when CVE-2025-14562 or the next vulnerability affects your stack