What’s Vulnerable › Vulnerabilities
CVE-2025-14576: Possible QML code injection in VectorImage component
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-30 · updated 2026-10-07
- Weakness: CWE-20
Description
Insufficient validation of node IDs in Qt SVG module allows arbitrary QML/JavaScript code injection when loading malicious SVG files through the VectorImage component in Qt Quick. While QML execution is typically more restricted than native code execution, this could still lead to denial of service, information disclosure, or other impacts depending on the application's privilege level and data access.
Affected products
- Qtdeclarative: from 6.8.0 before 6.8.6; from 6.10.0 before 6.10.1 — fixed in 6.10.1, 6.8.6
How to fix
Upgrade to a fixed version: Qtdeclarative 6.10.1, 6.8.6. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtdeclarative/+/697273
- https://access.redhat.com/errata/RHSA-2026:20567
- https://access.redhat.com/errata/RHSA-2026:24987
- https://access.redhat.com/errata/RHSA-2026:7620
- https://access.redhat.com/errata/RHSA-2026:7846
- https://access.redhat.com/security/cve/CVE-2025-14576
- https://bugzilla.redhat.com/show_bug.cgi?id=2464114
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-14576.json
Get alerted when CVE-2025-14576 or the next vulnerability affects your stack