What’s Vulnerable › Vulnerabilities

CVE-2025-14592: Missing Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.6 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions could have allowed an authenticated user to perform unauthorized operations by submitting GraphQL mutations through the GLQL API endpoint.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.6.6, 18.7.4, 18.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-14592 or the next vulnerability affects your stack