What’s Vulnerable › Vulnerabilities
CVE-2025-1467
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package tarteaucitronjs before 1.17.0 are vulnerable to Cross-site Scripting (XSS) via the getElemWidth() and getElemHeight(). This is related to [SNYK-JS-TARTEAUCITRONJS-8366541](https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8366541)
Affected products
- tarteaucitronjs: before 1.17.0 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: tarteaucitronjs 1.17.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Rudloff/d48f525215bd5426cbb076116c4422dd
- https://github.com/AmauriC/tarteaucitron.js/commit/12490579001d5caa187adcaecb01da570a12076b
- https://github.com/AmauriC/tarteaucitron.js/issues/1184
- https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8731160
Get alerted when CVE-2025-1467 or the next vulnerability affects your stack