What’s Vulnerable › Vulnerabilities
CVE-2025-1468: CODESYS Control V3 - OPC UA Server Authentication bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-18 · updated 2026-06-17
- Weakness: CWE-203
Description
An unauthenticated remote attacker can gain access to sensitive information including authentication information when using CODESYS OPC UA Server with the non-default Basic128Rsa15 security policy.
Affected products
- CODESYS Runtime Toolkit: before 3.5.21.0 — fixed in 3.5.21.0
How to fix
Upgrade to a fixed version: CODESYS Runtime Toolkit 3.5.21.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1468 or the next vulnerability affects your stack