What’s Vulnerable › Vulnerabilities
CVE-2025-14691: Mayan EDMS authentication cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-14 · updated 2026-10-07
- Weakness: CWE-79
Description
A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."
Affected products
- Mayan EDMS: before 4.10.2 — fixed in 4.10.2
How to fix
Upgrade to a fixed version: Mayan EDMS 4.10.2. Check the vendor advisory for mitigations.
References
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html#security
- https://github.com/ionutluca888/Mayan-EDMS-XSS-POC
- https://vuldb.com/?ctiid.336409
- https://vuldb.com/?id.336409
- https://vuldb.com/?submit.711713
Get alerted when CVE-2025-14691 or the next vulnerability affects your stack