What’s Vulnerable › Vulnerabilities
CVE-2025-1478: Allocation of Resources Without Limits or Throttling in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 8.13 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. A lack of input validation in Board Names could be used to trigger a denial of service.
Affected products
- GitLab: from 8.13.0 before 17.10.7; from 17.11.0 before 17.11.3; 18.0.0 — fixed in 17.10.7, 17.11.3
How to fix
Upgrade to a fixed version: GitLab 17.10.7, 17.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1478 or the next vulnerability affects your stack