What’s Vulnerable › Vulnerabilities
CVE-2025-14804: Frontend File Manager < 23.5 - Subscriber+ Arbitrary File Deletion
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-07 · updated 2026-10-07
Description
The Frontend File Manager Plugin WordPress plugin before 23.5 did not validate a path parameter and ownership of the file, allowing any authenticated users, such as subscribers to delete arbitrary files on the server
Affected products
- Frontend File Manager Plugin: before 23.5 — fixed in 23.5
How to fix
Upgrade to a fixed version: Frontend File Manager Plugin 23.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c572c0ad-1b36-49ce-b254-2181e53abb46/
- https://wpscan.com/vulnerability/c572c0ad-1b36-49ce-b254-2181e53abb46/
Get alerted when CVE-2025-14804 or the next vulnerability affects your stack