What’s Vulnerable › Vulnerabilities
CVE-2025-14821: Libssh: libssh: insecure default configuration leads to local man-in-the-middle attacks on windows
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-10-14
- Weakness: CWE-427
Description
A flaw was found in libssh. This vulnerability allows local man-in-the-middle attacks, security downgrades of SSH (Secure Shell) connections, and manipulation of trusted host information, posing a significant risk to the confidentiality, integrity, and availability of SSH communications via an insecure default configuration on Windows systems where the library automatically loads configuration files from the C:\etc directory, which can be created and modified by unprivileged local users.
Affected products
- libssh: before 0.12.0 — fixed in 0.12.0
- RedHat Hardened Images: all versions
How to fix
Upgrade to a fixed version: libssh 0.12.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:7067
- https://access.redhat.com/security/cve/CVE-2025-14821
- https://bugzilla.redhat.com/show_bug.cgi?id=2423148
- https://www.libssh.org/2026/02/10/libssh-0-12-0-and-0-11-4-security-releases/
Get alerted when CVE-2025-14821 or the next vulnerability affects your stack