What’s Vulnerable › Vulnerabilities
CVE-2025-14840: HTTP Client Manager - Less critical - Information disclosure - SA-CONTRIB-2025-126
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-754
Description
Improper Check for Unusual or Exceptional Conditions vulnerability in Drupal HTTP Client Manager allows Forceful Browsing.This issue affects HTTP Client Manager: from 0.0.0 before 9.3.13, from 10.0.0 before 10.0.2, from 11.0.0 before 11.0.1.
Affected products
- Drupal HTTP Client Manager: before 9.3.13; from 10.0.0 before 10.0.2; 11.0.0 — fixed in 10.0.2, 9.3.13
How to fix
Upgrade to a fixed version: Drupal HTTP Client Manager 10.0.2, 9.3.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-14840 or the next vulnerability affects your stack